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1.0
Introduction

This document provides a description for the use of the NPROVS Archive Statistical Summary (NARCS). NARCS was developed under contract to the Operational Products Development Branch (OPDB) of the Satellite Meteorology and Climatology Division (SMCD) of the Center for Satellite Applications and Research (STAR) of the National Environmental Satellite, Data and Information Service (NESDIS) of the National Oceanic and Atmospheric Administration (NOAA).

The basic purpose of NARCS is to provide a graphical view of long-term trending statistics for temperature and moisture at selected pressure levels. The pre-calculated statistics displayed in NARCS show the accuracy of temperature and moisture soundings from a variety of satellite processing systems compared to a baseline system, usually a radiosonde observation. 

The temperature and moisture data from which the statistics are computed are obtained from the NPOESS Product Validation System (NPROVS). The NPROVS system itself was designed to collocate radiosonde observations with soundings from various satellite processing systems including NOAA ATOVS, GOES, Aqua-Airs, NOAA IASI, MIRS, COSMIC, EUMETSAT IASI and EUMETSAT ATOVS.

[Describe where the stats come from]

1.1 NPROVS

A quick “what is nprovs”

Collocating satellites with baseline (radiosonde)

Collocations written to a daily file

1.2 How the stats are generated

A pre-existing NARCS file contains data from previous days


- the header of the NARCS file tells the stat generation program which levels to create stats for and which satellites to use

Daily file processed each day

Running sums are created, stats are calculated, the results written to the NARCS file

1.3
Description of the stats

2.0
Installing ProfileDisplay

ProfileDisplay is a Java application. As such, it can be run on any platform (Macintosh, Windows, Linux, etc.) on which Java has been installed. The entire program is contained within the file ProfileDisplay.jar. This is a Java archive file, which is a file compressed using the standard ZIP format that contains all of the code, file data and images used by the program.

In order to install PDISP, all that is necessary is to copy the ProfileDisplay.jar file to any location on a computer. The actual location does not matter, but for the sake of consistency it is probably a good idea to place it in the same location as other programs. For Windows users this will typically be the “Program Files” directory. For Macintosh users it can be placed within the “Applications” directory.

2.1
Obtaining And Installing Java

NARCS requires Java 1.4 or greater.

In order for NARCS to run, Java must be installed on your computer. This section will provide a brief description of how to obtain and install Java. But it is the responsibility of each user to make sure that Java is installed correctly.

To determine whether or not Java is installed on a computer, go to the command line and type the command:

java –version
If Java is installed, this command will generate a message that describes the version of Java that is installed. If Java is not installed, it will generate an error message stating that the command was not found. It should be noted, however, that it is possible for a command not found message to be generated even if Java is installed. This will occur when the java command is not located within the current path. If this is the case, then you will need to make sure that your path is updated to include the java command.

If Java is not installed, it can be obtained by going to the web site:

http://java.sun.com/

From this page you will need to locate the download. Look for the latest version of Java 2 Standard Edition (J2SE). If you have a choice between downloading the Java Runtime Environment (JRE) and the Software Development Kit (SDK) you should choose the JRE unless you plan to write your own Java programs. Once you download the program, the installation process will usually be straightforward.

2.3
Running The Program

There are two methods available for running ProfileDisplay. The first method is to go to the command line, switch to the directory that contains ProfileDisplay.jar, and type the command:


java –jar ProfileDisplay.jar

The second way to run PDISP will usually be the easiest. On most operating systems all you need to do is double-click the ProfileDisplay.jar icon just like you would if you were running any other program. This will kick off Java and start running PDISP.


3.0
Using NARCS

When NARCS begins running a window will open up. Whether or not any data is immediately displayed will depend on how the program is executed. In general, if NARCS is run from the website using Java Webstart, a default data file will be contained within the program. If that is the case then the program will read the file and display data. If NARCS is not run using Java Webstart, then the program will likely open with a blank window. In this case, it will be necessary to select a NARCS file to view by using the Open command that is located in the File menu.

3.0.1
Tabbed Panels

Near the top of the NARCS window are three tabs (figure 1). Each tab corresponds to one of three panels that contain data. The sample size panel shows the number of soundings that were collocated to the baseline system. The temperature and moisture panels show the actual statistics.
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Figure 1 — Tabs for tabbed panels on a Macintosh (top) and Windows (bottom).
3.1
Profile Panel

Theprofile panel displays individual profile data for each collocation. The main part of the panel contains a graph on which temperature and dewpoint temperature profiles are plotted (figure 2).

To the right of the graph is a list of all available profiles for the current collocation. If a profile is available, it will be displayed in a specific color. When a profile is not available, the profile name will be grayed out and the checkbox will be disabled. The two columns of checkboxes to the left of the profile name are used to turn the corresponding profiles on or off. The left-most column contains the checkboxes for temperature profiles. The second column is for dewpoint temperature profiles.

Beneath the graph is an area containing basic information about each displayed satellite. For some systems, such as radiosondes, additional information is displayed immediately after the system name. For radiosondes, the extra information is the instrument type.
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Figure 2 — PDISP window showing the profile panel. Temperature (solid) and dewpoint temperature (dashed) profiles for several satellites are displayed.
The lower right corner of the profile panel contains controls that provide the ability to switch between collocations. The left and right arrow buttons are used to switch to the previous and next collocation respectively. The text field between the arrow buttons can be used to enter a specific collocation number. In addition to these controls, the keyboard arrow keys can be used. The left and right keyboard arrow keys function in the same way as the corresponding arrow buttons. The up arrow key can be used to advance ten collocations at a time. The down arrow key will move backwards ten collocations at a time.

Immediately above the arrow buttons is a label that shows the number of available collocations and the total number of collocations in the file. When a sub-selection of collocations is made, the number of available collocations will change to reflect the number the match the sub-selection options.

3.1.1
Zooming and Scrolling

By default, the profile graph displays each profile from the bottom of the atmosphere to the top. Although this provides a good overview of the matchup, it is sometimes difficult to see the exact difference between the profiles. In this case, zooming in on a portion of the graph can be helpful.

The zoom in function can be selected from the Tools menu or by clicking the icon in the toolbar. The program will then enlarge the graph. Additional zooming can be done be selecting “Zoom In” again. Zooming in can be done up to three times.

To return to a larger view of the graph, go to the Tools menu and select “Zoom Out”. 

When zooming is enabled, only a portion of the graph will be visible. To view a different part of the graph it will be necessary to scroll or pan. Scroll bars appear on the right side and bottom of the graph when zooming is on. These can be used to scroll around the graph.

In addition to scrolling, it is possible to use panning to move around the graph. To do this, move the mouse pointer over the graph. Then press the mouse button. With the button still held down, move the mouse pointer around the graph.

3.1.2
Changing The Plot Type

When PDISP is first started, the default plot type will be a Skew-Temperature Log-Pressure plot with the pressure range from 1000 mb up to 100 mb. The plot type can be changed by selecting “Change Plot Type” from the Tools menu in the menu bar. A dialog will appear that shows the different graph options (figure 3).

There are eight types of pre-defined plots. To change the plot type, click on the image of the desired plot type. This will immediately cause the profile graph to change to the new plot type. Selecting the OK button will get rid of the dialog will keeping the new selection. Selecting the Cancel button will get rid of the dialog and cause the graph to revert back to the previous setting.
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Figure 3 — Pressure scale selection dialog
The eight pre-defined plot types are divided into two groups. One group, which are the five shown on the left side of the dialog, are standard XY plots. The other group, on the right side of the dialog, are Skew-Temperature Log-Pressure plots.

P2/7
This plot was selected because it does a reasonably good job of showing the profiles from the surface to the top of the atmosphere. With this scale, 100 mb is plotted approximately in the middle of the Y-axis.

Linear
The linear plot uses the pressure values themselves to determine where to plot each pressure. This plot type overemphasizes the lower atmosphere while squeezing the upper atmosphere into a small area.

Logarithmic
This plot type plots the pressure values on a strictly logarithmic scale. This is essentially the opposite of the linear scale since the upper atmosphere is highlighted at the expense of the lower atmosphere.

Special 1
This is a scale that was created to provide a better balance between the upper and lower atmosphere. It is a modified linear scale. The pressures are plotted as three separate linear scales: 0.1 mb to 100 mb, 100 mb to 500 mb, and 500 mb to 1000 mb. The 100 mb pressure is plotted so that it is 1/4 of the way down the axis while the 500 mb pressure is plotted 1/2 way down the axis.

Special 2
The Special 2 scale is the same as the Special 1 scale. The difference is the location of the 100 mb and 500 mb pressures. The 100 mb pressure is 1/3 of the way down the axis. The 500 mb pressure is 2/3 of the way down the axis.

Skew-T Plots
The three Skew-T Log-P plots are essentially the same. The only difference between them is the upper pressure limit.

3.1.3
Displaying Grid Lines, Data Points and Cloud Data

The graph can be modified to turn grid lines on and off. The display of individual data points for each profile can also be toggled. A third option the display of cloud top data.

All three functions can be turned on or off by selecting the appropriate option from the Tools menu. The grid line option, which is only available an XY plot is selected, will draw grid lines behind the graph to make it easier to match a point on a profile with corresponding temperatures and pressures. With the option turned off (figure 4) the grid lines will not be displayed.
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Figure 4 — Profiles with grid line option turned off (left) and on (right)
The option to display data points will draw a circle on top of each profile at the location of each actual data point (Figure 5).
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Figure 5 — Profile data with data point option turned off (left) and on (right)
Some files contain cloud data. If the cloud data option is turned on in the Tools menu and the current matchup contains cloud data, a horizontal line will be drawn across the temperature profiles (figure 6). The location of this line on the Y-axis shows the pressure of the top of the cloud. To the right of the line is a label showing the actual pressure of the cloud top. To the right of that is a percentage which shows the cloud percentage.

The color of the cloud line will vary depending on the type of cloud. For normal water vapor clouds the color of the line will be light gray. If the cloud is caused by aerosol contamination the color of the line will be brown.
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Figure 6 — Cloud option turned on. The gray line shows the pressure of the top of the cloud. The exact pressure and cloud percentage is displayed next to the line.
3.1.4
Searching For Radiosonde Station IDs.

When viewing matchups it is possible to search for specific radiosonde station ID’s. This feature is invoked by selecting “Find Radiosonde” from the Tools menu. This will bring up a dialog (figure 7) that lists all of the radiosonde station ID’s that are located in the selected file.

To select a specific radiosonde, click the station ID in the list and click the OK button. The first matchup in the file containing the selected radiosonde will appear. To advance to the next matchup containing the station ID (if another one exists), go to the Tools menu and select “Find Next Radiosonde”. Both the “Find Radiosonde” and “Find Next Radiosonde” options have keyboard shortcuts, ctrl-F and ctrl-G respectively, that can be used instead of going to the menu each time.
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Figure 7 — Find radiosonde dialog.
3.2
Raw Data Panel

While the profile panel provides a good overview of each collocation, it is sometimes desirable to view the data more closely. The raw data panel accomplishes this by displaying all available data for each group of data in a collocation.

The raw data is divided into several sections. The first section lists the dates and times of the groups of data. The second section contains a table of the specific temperature and moisture values. The rows of the table represent each pressure level. The columns contain the temperature and moisture data. The remaining sections contain the raw data from each satellite. Each section can be viewed by using the list in the lower left corner of the panel to select one of the sections.

3.3
Geographic Map Panel

The geographic map panel (Figure ) has two functions. The first function is the display of the location of each collocation. The second function is to allow for the sub-selection of collocations. The geographic map panel accomplishes both functions with a map along with a variety of sub-selection controls.
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Figure 8 — Geographic map panel with sub-selection controls.
3.3.1
Geographic Map

The geographic map displays all collocations that meet the current sub-selection settings. Each collocation is plotted on the map at the location of the baseline system (typically the radiosonde). The color of the circle represents the terrain type of the radiosonde using terrain values defined by the NPOESS Product Validation System (NPROVS).

Several additional options are available when plotting each collocation location. From the Tools menu, it is possible to display the radiosonde station ID, radiosonde instrument type number or radiosonde instrument type name alongside the collocation location.

Another display option is the inclusion of the location of each satellite in relation to the radiosonde (figure 9). When selected, this option will display the color-coded location of each satellite.
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Figure 9 — Locations of collocated satellites in relation to radiosondes (red R).
The radiosonde balloon drift is another display option on the geographic map. The course of the balloon as it ascended is plotted in a magenta line beginning at the location of the radiosonde (figure 10).
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Figure 10 — Radiosonde balloon drift. The purple line shows the location of the balloon as it ascended.
The “Show Distance Between Points” menu and toolbar icon can be selected to show the distance between any two points on the map. Pressing the mouse button and dragging the mouse will draw a line on the map and display the distance from the beginning of the line to the end of the line (figure 11).
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Figure 11 — Displaying the distance between two points. The distance updates as the mouse pointer is moved.

3.3.2
Sub-selection

The sub-selection controls provide a highly flexible way to choose which collocations to display. When one or more of the controls is set, only collocations that match the settings will be displayed on the geographic map, in the profile panel, and in the raw data panel. The sub-selection settings are also used when generating vertical accuracy statistics and scatter plots.

The geographic map can be used to quickly select specific collocations or areas. When the “Subselect Using Rectangles” option is chosen from the Tools menu or from the toolbar, a rubber-band box can be draw on the map (figure 12). When the mouse is released after drawing the box, most of the map will turn gray while the selected area will be white with a red outline. Additional areas may be selected by holding down the Shift key while drawing another box. Collocations within the boxes will be available.
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Figure 12 — Sub-selection using geographic areas. Two areas have already been selected (Eastern United States and Atlantic Ocean). A third area is being drawn around Hawaii.
The group availability, quality control and terrain options are used to sub-select based on satellite settings (figure 13). One row of controls is present for each satellite and radiosonde. The first column responds to the availability of the corresponding satellite. The drop-down list has three options: “Yes or No”, “Yes” and “No”. When “Yes” is selected, a collocation will be available only if it contains data for the satellite. A “No” selection will reject collocations that have data for the satellite. The “Yes or No” option, when selected, will allow a collocation to be used regardless of whether or not it contains data for the satellite.

The second column is for the quality control options. It also contains three options: “Pass/Fail”, “Pass” and “Fail”. When set to “Pass”, collocations are used only when the satellite’s quality flag is set to “Pass”. The “Fail” option is used to display collocations where the satellite failed its quality checks. The “Pass/Fail” option will result in a collocation being used regardless of the quality setting.

The last two columns are used to sub-select based on the cloud flag and terrain flag of each satellite. If a satellite does not contain the necessary data, such as a terrain value, the control will be disabled.
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Figure 13 — Group availability, quality control and terrain sub-selection controls.
Several sub-selection controls are available for various radiosonde options (figure 14). The terrain and raob time checkboxes can be selected or deselected to choose collocations that match selected terrains and times. The network controls are used to display radiosonde that belong to pre-defined radiosonde networks. The drift data checkboxes allow sub-selection based on whether or not the radiosonde contains balloon drift data. The remaining controls are used to choose various radiosonde quality controls.

The time and distance controls are used to sub-select based on the difference in time or distance between satellites and the radiosonde (figure 15). The time controls will limit the time difference between satellite and the baseline system based on the time before and time after settings. When set to values other than “No Limit”, a collocation will not be available if the satellite if outside of the selected window. The distance control works in a similar way.
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Figure 14 — Radiosonde sub-selection controls.
The radiosonde ID section contains a list of all radiosonde station IDs that are available in the file. If a checkbox is not selected, then all collocations with the unselected station IDs will not be available.

The instrument type section contains a list of all currently defined radiosonde instrument types. Instrument types that are not contained within the file are disabled.

The last sub-selection control is a date and time slider. This slider is used to select the starting and ending points of the time window. Collocations that are within the time window are available.

In the corner of the geographic map panel is a “Turn All On” button. When pressed, all sub-selection settings are reset.
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Figure 15 — Collocation closeness, radiosonde station ID and instrument type sub-selection controls.
3.4
Vertical Statistics Panel

While it is useful to view data from individual collocations, it is often helpful to view a summary of the data over a selected period of time. This is most easily done by computing vertical accuracy statistics.

The process of computing vertical statistics is begun by selecting “Compute Vstats” from the Statistics menu. A dialog will appear (figure 16) that provides several options. The right side of the dialog contains checkboxes for every available profile. Statistics will be generated for all selected profiles.

At the top of the left side of the dialog is a text field that can be used to enter a description of the generated statistics. This feature is not used in the current version of ProfileDisplay but will be enabled in a future version.

Beneath the description field is a list of all available profiles. One profile from this list can be selected as the baseline profile. By default, the baseline profile will be the radiosonde to which all satellites have been collocated. But this can be changed to any available profile. When the statistics are computed, the difference between each of the selected profiles and the baseline profile will be calculated.
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Figure 16 — Vertical statistic selection dialog.
Several pressure level options are available: 42 ATOVS levels (older definition), 42 ATOVS levels (new definition), and 100 MIRS pressure levels. Data from each system will be interpolated, if necessary, to the chosen pressure levels.

After the selections are made, the program will begin generating the vertical accuracy statistics. The current sub-selection settings are used to determine which collocations to use. For each collocation, temperature and moisture data are read for each profile. A running sum of the differences between each profile and the baseline profile is maintained at each pressure level.

When all of the collocations have been processed, a new vertical statistic graph will be available in the Vstat panel (figure 17). The left side of the graph shows the pressure level in black and the baseline mean in gray. Along the right side of the graph is the sample size at each level. As the mouse pointer is moved up and down on the graph, the data values corresponding to the nearest pressure level are displayed beneath the graph.

Various controls are positioned along the right side of the window. These controls allow for changes in the type of data being displayed and the manner in which the data are displayed. The data type, retrieved temperature or water vapor, can be selected from the drop-down list at the top. The type of statistic can be selected using the checkboxes beneath the data type. Beneath that are checkboxes for each profile that can be selected or unselected to toggle the display of data for the chosen profile.
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Figure 17 — Vertical statistic window.
At the bottom is a control that modifies the x-axis scale. Two options are available: default and automatic. When the default scale is selected, the minimum and maximum values on the x-axis will be set to values that are pre-defined based on the current data type. When the automatic option is selected, the minimum and maximum values will be adjusted based on the actual minimum and maximum values of the displayed data.

3.5
Scatter Plot Panel

The scatter plot option in ProfileDisplay creates a basic scatter plot of selected data that compares data from satellites with data from a baseline system, typically a radiosonde. To generate a scatter plot, select “Compute Scatter Plot” from the Statistics menu. A dialog will appear that is similar to the one used when creating vertical accuracy statistics.

After the options are chosen, PDISP will read every collocation that matches the current sub-selection settings. The result will appear in the scatter plot panel (figure 18). The baseline system values are plotted along the x-axis while the data values for the comparison profiles are plotted along the y-axis.
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Figure 18 — Scatter plot window showing retrieved temperatures at 500 mb.
When a scatter plot is generated, the scatter plot panel will contain one graph for each pressure level. The graph for a specific level can be viewed by adjusting the pressure level slider.

In the lower right portion of the scatter plot panel is a slider that controls the size of the circles on the graph. ProfileDisplay will, by default, choose a circle size that is generally appropriate based on the size of the window. There are times, however, when it may desirable to change the circle size. In some cases, an appropriate circle size can be difficult to accurately calculate. In other cases, changing the size of the circles can emphasize or deemphasize selected data.

3.5.1
Sub-selection From The Scatter Plot Panel

One of the advantages of generating a scatter plot graph is the ability to quickly view outlying data points. When such outliers are identified, a logical next step is to view the collocations that produced the outlying data. ProfileDisplay assists in this with a feature that allows a user to draw a rectangle or polygon around interesting points. To use this feature from within the scatter plot panel, choose “Subselect Using Rectangles” or “Subselect Using Polygons” in the Tools menu or by selecting one of the icons in the toolbar.

The rectangle option can be used to draw a rubber-band box anywhere on the graph. Pressing the mouse button will begin the drawing of the rectangle. When the mouse is moved while the mouse button remains pressed, a rectangle will be drawn.

The polygon option is used to draw an irregularly shaped polygon. After this option is turned on, the polygon is drawn by clicking various points on the graph. The first point in the polygon will be represented by a green square. Subsequent points are represented by orange squares. To complete the polygon, click on the first (green) square. To cancel a polygon, press the Escape key.
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Figure 19 — Sub-selecting data points on a scatter plot. A rectangle area has already been defined in the lower left of the graph. A second area, beneath the center of the plot, is in the process of being defined as a polygon.
When an area has been defined on the graph, the selected area will be white while everything outside of the selected area will be in gray (figure 19). Multiple areas can be defined by pressing and holding the shift key while beginning a new rectangle or polygon.




Running NARCS With Additional Memory





Running NARCS from the command line with the java command or by double-clicking the application will execute the program with a default amount of memory. The amount of memory varies and is usually determined by the installed Java runtime environment. Typically, the amount of default memory is adequate. But if additional memory is desired, NARCS can be given extra memory using one of two methods:





From the command line, use the command:  java –mx256m –jar NARCS.jar


A batch file or run script can be created that contains the above command. The batch file or script can then be double-clicked.





The –mx256m part of the command will reserve 256 megabytes of memory for the program. This number can be set to any desired value. It should be noted, however, that increasing the amount of memory for NARCS will decrease the amount of system memory available for other programs.
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